Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Latency and Timeout Errors with Twilio Rest API Impacting Multiple Products
Incident Report for Twilio
Resolved
The incident causing timeout errors within a subset of Serverless Functions has been resolved. Those affected would have observed timeout errors in the execution of their Function(s) between 12:00am and 08:29am Pacific. Serverless Functions are now operating normally. This incident is resolved.
Posted Jan 13, 2022 - 10:24 PST
Update
The incident causing timeout errors within a subset of Serverless Functions has been resolved. Those affected would have observed timeout errors in the execution of their Function(s) between 12:00am and 08:29am Pacific. Serverless Functions are now operating normally. This incident is resolved.
Posted Jan 13, 2022 - 09:51 PST
Update
The incident causing timeout errors has been investigated and at present we don't see any additional timeouts. We are continuing to monitor this incident for an additional 2 hours to ensure the service is stable and no other customers are affected. For those affected, we will continue working individually for full resolution.
Posted Jan 13, 2022 - 08:24 PST
Monitoring
The incident causing timeout errors has been investigated and at present we don't see any further timeouts. We are monitoring this incident for 2 hours and will reach out to the affected customers individually for further follow-ups.
Posted Jan 13, 2022 - 06:27 PST
Update
We are currently investigating an issue with latency and timeout errors on Twilio's Rest API. Multiple products are impacted. Our engineers are working on the issue, and we will provide another update in the next 1 hour or when more information becomes available.
Posted Jan 13, 2022 - 04:55 PST
Update
We've become aware of a potential issue with Serverless Function. Our engineering team has been alerted and is actively investigating. We will provide another update in the next 30 minutes or when more information becomes available.
Posted Jan 13, 2022 - 02:55 PST
Investigating
We've become aware of a potential issue with Serverless Function. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jan 13, 2022 - 02:48 PST
This incident affected: SERVERLESS (Studio, Functions, Sync).