Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Mobitel Network in Sri-Lanka for Messages from Numeric Sender ID
      Incident Report for Twilio
      Resolved
      We have fully investigated the SMS delivery delays when sending messages from numeric sender IDs to Mobitel Network in Sri-Lanka. It was determined that the impact was limited to a small set of customers. We will be contacting affected customers individually to address any concerns. This incident is now resolved.
      Posted Jul 23, 2021 - 13:37 PDT
      Update
      We continue to work with our carrier partner to resolve the issue of SMS delivery delays when sending messages to Mobitel Network in Sri-Lanka for messages from numeric sender ID. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Jul 23, 2021 - 12:20 PDT
      Update
      We are continuing to work with our carrier partner to resolve the issue of SMS delivery delays when sending messages to Mobitel Network in Sri-Lanka for messages from numeric sender ID. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Jul 23, 2021 - 10:20 PDT
      Investigating
      We are experiencing SMS delivery delays when sending messages to Mobitel Network in Sri-Lanka for messages from numeric sender ID. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jul 23, 2021 - 09:21 PDT
      This incident affected: CARRIER NETWORK (SMS, APAC).