Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS and MMS Delivery Delays to T-Mobile network In US via Subset of Short codes
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS and MMS delivery delays when sending messages to T-Mobile network in US via Subset of Short codes. This incident has been resolved.
      Posted Apr 22, 2024 - 13:58 PDT
      Monitoring
      We are observing recovery in SMS and MMS delivery delays when sending messages to T-Mobile network In US via Subset of Short codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Apr 22, 2024 - 12:11 PDT
      Update
      We are observing recovery in SMS delivery delays however, we continue to experience MMS delivery delays when sending messages to T-Mobile network In US via Subset of Short codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Apr 22, 2024 - 04:14 PDT
      Update
      We are continuing to experience SMS and MMS delivery delays when sending messages to T-Mobile network In US via Subset of Short codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Apr 22, 2024 - 00:19 PDT
      Update
      We are continuing to experience SMS and MMS delivery delays when sending messages to T-Mobile network In US via Subset of Short codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Apr 21, 2024 - 22:18 PDT
      Investigating
      We are experiencing SMS and MMS delivery delays when sending messages to T-Mobile network In US via Subset of Short codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Apr 21, 2024 - 21:18 PDT
      This incident affected: CARRIER NETWORK (SMS Short Code, North America, MMS Short Code, North America).