Reseller customers being unable to invite users to accounts from the Twilio console has been resolved and the service is operating normally at this time.
Posted Nov 10, 2025 - 04:37 PST
Monitoring
We are observing recovery in reseller customers being unable to invite users to accounts from the Twilio console. We will continue monitoring the service to ensure a full recovery. We will provide another update in one hour or as soon as more information becomes available.
Posted Nov 10, 2025 - 04:34 PST
Update
Reseller customers are currently unable to invite users to accounts from the Twilio Console. Our engineers have identified the issue and are actively working to deploy a fix. We will provide another update within four hours or as soon as more information becomes available.
Posted Nov 10, 2025 - 02:45 PST
Update
Reseller customers are currently unable to invite users to accounts from the Twilio Console. Our engineers have identified the issue and are actively working to deploy a fix. We will provide another update within two hours or as soon as more information becomes available.
Posted Nov 10, 2025 - 00:55 PST
Investigating
Reseller customers are currently unable to invite users to accounts from the Twilio Console. Our engineers have identified the issue and are actively working to deploy a fix. We will provide another update within one hour or as soon as more information becomes available.
Posted Nov 09, 2025 - 23:59 PST
This incident affected: DEVELOPER TOOLS (Console).