We are no longer experiencing SMS delivery receipt delays to multiple networks in US via a subset of Twilio short codes. This incident has been resolved.
Posted Sep 15, 2024 - 19:50 PDT
Monitoring
We have started seeing recovery for intermittent SMS delivery receipt delays to multiple networks in US via a subset of Twilio short codes. We will continue to monitor to ensure a full recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 15, 2024 - 17:53 PDT
Update
We were experiencing SMS delivery receipt delays to multiple networks in US via a subset of Twilio short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available
Posted Sep 15, 2024 - 17:06 PDT
Investigating
Our monitoring systems have detected a potential issue with SMS Delivery Reporting Delays To Multiple Networks In US Via A Subset Of Twilio Shortcodes . Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 15, 2024 - 16:44 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America).