Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Outbound SMS to MCI network in Iran degraded
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Oct 10, 2019 - 03:06 PDT
      Investigating
      SMS delivery to the MCI network in Iran has degraded delivery. We are investigating and working with our partners. We will provide an update when we have further information.
      Posted Oct 10, 2019 - 01:39 PDT