Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays and Failures to Tanzania
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Nov 25, 2022 - 15:26 PST
      Monitoring
      We are observing recovery in SMS delivery delays and failures when sending messages to Tanzania. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 25, 2022 - 13:33 PST
      Update
      We continue to experience SMS delivery delays and failures when sending messages to Tanzania. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Nov 25, 2022 - 05:30 PST
      Update
      We continue to experience SMS delivery delays and failures when sending messages to Tanzania. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Nov 25, 2022 - 01:30 PST
      Update
      We continue to experience SMS delivery delays and failures when sending messages to Tanzania. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 24, 2022 - 23:32 PST
      Investigating
      We are experiencing SMS delivery delays and failures when sending messages to Tanzania. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Nov 24, 2022 - 22:32 PST
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).