Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Outbound US Toll Free SMS delays.
Incident Report for Twilio
Resolved
The delays in outbound SMS delivery and DLRs for toll-free US numbers have been resolved.
Posted Nov 27, 2019 - 13:47 PST
Monitoring
We're now seeing resolution for DLRs as well as continued performance on outbound delivery times for toll-free SMS in the US. We'll continue to monitor this issue and provide an update if there are any changes.
Posted Nov 27, 2019 - 12:48 PST
Update
We're seeing recovery for outbound delivery delays from toll-free US numbers. Our team is still working to resolve delays for DLRs on these messages. We'll provide more updates as the become available.
Posted Nov 27, 2019 - 12:11 PST
Identified
We are continuing to work with our carrier partner to resolve the outbound delays for toll-free SMS in the US. We'll provide additional updates as they become available.
Posted Nov 27, 2019 - 10:52 PST
Investigating
We are currently observing message delivery delays via US Toll Free Numbers to US devices. Our engineers are working with our carrier partner to investigate the issue. We will provide an update as soon as we have additional information.
Posted Nov 27, 2019 - 08:54 PST
This incident affected: CARRIER NETWORK (SMS Toll-Free, North America).