Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS delivery degradation towards Du network in UAE
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 10 days ago. Aug 08, 2019 - 17:03 PDT
Update
We continue to see delivery issues to the Du network in UAE. We continue to work with our carrier partners to resolve the issue, and we will provide additional details as they become available.
Posted 10 days ago. Aug 08, 2019 - 12:12 PDT
Investigating
We have detected an issue with delivery degradation towards Du UAE network when sending SMS from Twilio phone numbers. We are working with our carrier partners to resolve the issue and will provide an update as soon as possible.
Posted 11 days ago. Aug 08, 2019 - 07:30 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).