Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
US Short Code delivery delays towards T-Mobile handsets
Incident Report for Twilio
Resolved
All services are operating normally.
Posted 6 months ago. Sep 05, 2018 - 19:14 PDT
Update
We are seeing recovery for delivery delays for messages sent from US Short Code towards T-Mobile handsets. Our engineering team will continue to monitor the service.
Posted 6 months ago. Sep 05, 2018 - 18:58 PDT
Monitoring
We are seeing recovery for delivery delays for messages sent from US Short Code towards T-Mobile handsets. Our engineering team will continue to monitor the service.
Posted 6 months ago. Sep 05, 2018 - 18:57 PDT
Identified
We are experiencing delivery delays for messages sent from US Short Code towards T-Mobile handsets. Our engineers are working with our carrier partner to resolve the issue. We will provide additional information as quickly as possible.
Posted 6 months ago. Sep 05, 2018 - 18:47 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America).