United States SMS and MMS Carrier Maintenance - T-Mobile The T-Mobile network in the United States is conducting a planned maintenance from 12 March 2025 at 19:00 PDT until 13 March 2025 at 05:00 PDT. During the maintenance window, there could be intermittent delays delivering SMS and MMS to and from T-Mobile United States handsets.
Posted Mar 12, 2025 - 13:20 PDT
Scheduled
The T-Mobile network in the United States is conducting a planned maintenance from 12 March 2025 at 19:00 PDT until 13 March 2025 at 05:00 PDT. During the maintenance window, there could be intermittent delays delivering SMS and MMS to and from T-Mobile United States handsets.
Posted Mar 06, 2025 - 18:23 PST
This scheduled maintenance affected: CARRIER NETWORK (SMS Long Code, North America, MMS Long Code, North America, SMS Short Code, North America, MMS Short Code, North America, SMS Toll-Free, North America, MMS Toll-Free, North America) and ZIPWHIP MESSAGING (SMS Long Code, North America, MMS Long Code, North America, SMS Toll-Free, North America, MMS Toll-Free, North America).