Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Short code and long code SMS delivery delays in the US
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Jun 26, 2019 - 08:22 PDT
      Monitoring
      We're seeing a recovery in SMS delivery. We will continue to monitor closely for the next 30 minutes.
      Posted Jun 26, 2019 - 08:10 PDT
      Investigating
      We have detected SMS delivery delays for messages sent to a subset of US short codes from US handsets and for long code SMS sent from US Verizon handsets towards US long codes. We are working with the carrier to resolve the issue and will provide additional information as it becomes available.
      Posted Jun 26, 2019 - 07:56 PDT
      This incident affected: CARRIER NETWORK (SMS Long Code, North America, SMS Short Code, North America).