Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Issue With Programmable Wireless Usage and Billing
Incident Report for Twilio
Resolved
We are no longer experiencing delay in data usage reporting and billing for the Programmable Wireless product. This incident has been resolved.
Posted Aug 01, 2020 - 22:17 PDT
Update
We are continuing to monitor our fix for the issue that caused delayed data usage reporting and billing for the Programmable Wireless product. Our next update will occur at 11:45 pm PT.
Posted Aug 01, 2020 - 12:00 PDT
Update
We are continuing to monitor our fix for the issue that caused delayed data usage reporting and billing for the Programmable Wireless product. Our next update will occur at 11:45 am PT.
Posted Aug 01, 2020 - 07:44 PDT
Update
We are continuing to monitor for any further issues.
Posted Aug 01, 2020 - 05:47 PDT
Monitoring
The issue has been fixed. For the time being there is still a delay in processing, but we are seeing recovery to near normal levels on the data usage and billing pipeline. We will provide an update within 2 hours.
Posted Aug 01, 2020 - 03:44 PDT
Identified
The issue has been identified and a fix is being implemented. For the time being there is still a delay in processing, but we are starting to seeing a recovery on the data usage and billing pipeline. We will provide an update within 2 hours.
Posted Aug 01, 2020 - 01:34 PDT
Update
Data usage reporting and billing is currently delayed for Programmable Wireless customers. Our engineers are investigating and we will provide an update within 1 hour.
Posted Aug 01, 2020 - 00:29 PDT
Investigating
Our monitoring systems have detected a potential issue with Programmable Wireless services. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Aug 01, 2020 - 00:13 PDT
This incident affected: INTERNET OF THINGS (Programmable Wireless).