Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Outbound SMS Delays to Excelcom, Indonesia
      Incident Report for Twilio
      Resolved
      We have received an update from our carrier partner that the issue affecting the Excelcom network operator in Indonesia has been resolved. Our engineers have confirmed from internal testing and metrics that SMS delivery rate has returned to normal.
      Posted Sep 18, 2018 - 03:28 PDT
      Identified
      We have detected an operator issue resulting in delays in sending SMS to the Excelcom network in Indonesia. We are working with our carrier partners to resolve the issue and will provide an update as soon as possible.
      Posted Sep 18, 2018 - 02:18 PDT
      This incident affected: PROGRAMMABLE MESSAGING (SMS).