Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS Delivery Delays to US Carriers on a subset of Twilio Short Codes
Incident Report for Twilio
Resolved
We are no longer experiencing MMS delivery delays to US carriers. This incident has been resolved.
Posted Nov 03, 2020 - 11:21 PST
Monitoring
We have disabled Picture SMS on the affected short codes, as we observe successful MMS delivery in the past 10 minutes. We will continue to monitor to ensure full service recovery. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Nov 03, 2020 - 10:57 PST
Update
We have temporarily enabled picture SMS on the affected short code numbers as a workaround while we continue to work with our carrier partner to resolve the issue. Subscribers will receive an SMS with a link to the picture instead. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 03, 2020 - 10:20 PST
Update
We have outbound messages fail over short code MMS. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 03, 2020 - 09:59 PST
Investigating
Our monitoring systems have detected a potential issue with MMS. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Nov 03, 2020 - 09:47 PST
This incident affected: CARRIER NETWORK (MMS Short Code, North America).