Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Cross Platform API Errors affecting Multiple Products
Incident Report for Twilio
Resolved
The issue impacting multiple products has been resolved, and Twilio services are operating normally at this time.
Posted Feb 26, 2021 - 09:34 PST
Monitoring
Twilio services are now operating normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
Posted Feb 26, 2021 - 09:04 PST
Update
Twilio services are now operating normally, however processing of Programmable Messaging queues was delayed during the incident. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Feb 26, 2021 - 08:55 PST
Update
We are no longer experiencing connection issues across multiple products, however Programmable Messaging queues of messages are still being processed. In particular, Twilio Console, REST API, and Flex access is restored. Our ability to process voice calls was unaffected. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Feb 26, 2021 - 07:55 PST
Identified
We are continuing to experience connection issues across multiple products such as Programmable Voice, Programmable SMS, Billing, Messaging API, Conversations API, Flex, Chat, Conversation, Super SIM, Verify API, Authy API, Console, Autopilot, REST API, Identity, Studio API, Phone Number API, Pricing API. Our engineers are working on finding a solution. Twilio Console and REST API access is being restored. Our ability to process voice calls is unaffected but auxiliary services may be operating in a degraded mode. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Feb 26, 2021 - 07:34 PST
Update
We are continuing to experience connection issues across multiple products such as Programmable Voice, Programmable SMS, Billing, Messaging API, Conversations API, Flex, Chat, Conversation, Super SIM, Verify API, Authy API, Console, Autopilot, REST API, Identity, Studio API, Phone Number API, Pricing API. Our engineers are working on finding a solution. Twilio Console access is being restored. Our ability to process voice calls is unaffected but auxiliary services may be operating in a degraded mode. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Feb 26, 2021 - 07:18 PST
Update
We are continuing to experience connection issues across multiple products such as Programmable voice, Programmable SMS, Billing, Messaging API, Conversations API, Flex, Chat, Conversation, Super SIM, Verify API, Authy API, Console, Autopilot, Gateway-Rest-API, Identity, Studio API, Phone Number API, Pricing API. Our engineers are working on finding a solution. Twilio console is not available at the moment. Our ability to process Voice Calls is unaffected but auxiliary services may be operating in a degraded mode. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Feb 26, 2021 - 06:18 PST
Update
We are experiencing connection issues across multiple products such as Programmable voice, Programmable SMS, Billing, Messaging API, Conversations API, Flex, Chat, Conversation, Super SIM, Verify API, Authy API, Console, Gateway-Rest-API, Identity, Pricing API. The Twilio console is not available at the moment.
Our engineers are working on finding a solution. We expect to provide another update in 30 minutes or as soon as more information becomes available
Posted Feb 26, 2021 - 05:48 PST
Update
We are continuing to investigate this issue.
Posted Feb 26, 2021 - 05:46 PST
Update
We are continuing to investigate this issue.
Posted Feb 26, 2021 - 05:44 PST
Investigating
Our monitoring systems have detected a potential issue with Conversation, Chat and Rest API. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Feb 26, 2021 - 05:25 PST
This incident affected: ACCOUNT SECURITY (Authy 2FA, Verify, Authy App, Lookup), DEVELOPER TOOLS (Console, REST API), FLEX (TaskRouter, Flex Application Platform, Flex Insights), TWILIO PLATFORM (Billing), PROGRAMMABLE CHAT, and PROGRAMMABLE MESSAGING (MMS, SMS, SMPP, Messaging Channels, Notify, Conversations).