Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Nigeria Glo Mobile
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery delays when sending messages to Nigeria Glo Mobile. This incident has been resolved.
Posted Jan 07, 2022 - 06:36 PST
Monitoring
We are observing recovery in SMS delivery delays when sending messages to Nigeria Glo Mobile. Our metrics are showing stabilisation of this traffic for the last 18 hours. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 07, 2022 - 04:35 PST
Update
We are continuing to work with our carrier partner to resolve intermittent SMS delivery delays to Nigeria Glo Mobile. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted Jan 06, 2022 - 17:49 PST
Update
We are continuing to work with our carrier partner to resolve intermittent SMS delivery delays to Nigeria Glo Mobile. We expect to provide another update in 16 hours or as soon as more information becomes available.
Posted Jan 06, 2022 - 01:50 PST
Update
We are continuing to work with our carrier partner to resolve intermittent SMS delivery delays to Nigeria Glo Mobile. We expect to provide another update in 8 hours or as soon as more information becomes available.
Posted Jan 05, 2022 - 17:58 PST
Update
We are continuing to work with our carrier partner to resolve intermittent SMS delivery delays to Nigeria Glo Mobile. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Jan 05, 2022 - 13:59 PST
Update
We are continuing to work with our carrier partner to resolve intermittent SMS delivery delays to Nigeria Glo Mobile. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 05, 2022 - 12:00 PST
Identified
The issue causing intermittent SMS delivery delays when sending messages to Nigeria Glo Mobile has been identified. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 05, 2022 - 11:01 PST
Update
We continue to work with our carrier partner to resolve the issue of intermittent SMS delivery delays when sending messages to Nigeria Glo Mobile. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted Jan 04, 2022 - 11:02 PST
Update
We are continuing to work with our carrier partner to resolve the issue of intermittent SMS delivery delays when sending messages to Nigeria Glo Mobile. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted Jan 03, 2022 - 11:01 PST
Update
We are continuing to investigate this issue.
Posted Jan 02, 2022 - 18:10 PST
Update
We are experiencing intermittent SMS delivery delays when sending messages to Nigeria Glo Mobile. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
Posted Jan 02, 2022 - 11:01 PST
Update
We are experiencing intermittent SMS delivery delays when sending messages to Nigeria Glo Mobile. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
Posted Jan 01, 2022 - 11:07 PST
Update
We are experiencing SMS delivery delays when sending messages to Nigeria Glo Mobile. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Jan 01, 2022 - 07:09 PST
Update
We are experiencing SMS delivery delays when sending messages to Nigeria Glo Mobile. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 01, 2022 - 05:17 PST
Investigating
We are experiencing SMS delivery delays when sending messages to Nigeria Glo Mobile. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 01, 2022 - 04:26 PST
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).