Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delays in Email Notifications for Port Status
Incident Report for Twilio
Resolved
The incident has been resolved.
Posted about 1 year ago. Mar 01, 2018 - 00:28 PST
Update
Email notifications of porting status changes are not currently firing. We believe that we have narrowed down the possible cause, but we still need to investigate further.
Posted about 1 year ago. Feb 28, 2018 - 23:23 PST
Investigating
Email notifications of porting status changes are not currently firing. We are investigating the issue.
Posted about 1 year ago. Feb 28, 2018 - 15:12 PST