Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inbound and outbound MMS delivery delays on AT&T US handsets
Incident Report for Twilio
Resolved
The MMS message delivery issue to and from AT&T US handsets over Twilio US longcodes and the delay in status callbacks are now resolved. We are observing full and stable MMS message delivery.
Posted Oct 31, 2019 - 22:38 PDT
Update
We are observing recovery in MMS delivery to and from AT&T US handsets over Twilio US longcodes. We are however observing delays in receiving status call backs. We are working with our carrier partner to resolve the issue and will provide an update as soon as we have more information.
Posted Oct 31, 2019 - 21:30 PDT
Investigating
We have detected outbound delivery delays sending MMS messages from Twilio longcodes to AT&T US handsets, as well as inbound delivery delays receiving MMS on Twilio long codes from AT&T US handsets. We are working with our carrier partner to resolve the issue and will provide an update when we have additional information available.
Posted Oct 31, 2019 - 19:35 PDT
This incident affected: CARRIER NETWORK (MMS Long Code, North America).