Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Malawi Telekom Networks
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery delays on Malawi Telekom Network in Malawi. This incident has been resolved.
      Posted May 29, 2020 - 18:38 PDT
      Monitoring
      We are observing successful delivery on Malawi Telekom Network in Malawi for the last 60 minutes. We will continue to monitor to ensure a full recovery.
      Posted May 29, 2020 - 17:45 PDT
      Update
      Our engineering team is still working along with our carrier partner to resolve this issue. We will provide an update as soon as we have additional information.
      Posted May 29, 2020 - 17:17 PDT
      Update
      Our engineering team is still working along with our carrier partner to resolve this issue. We will provide an update as soon as we have additional information.
      Posted May 29, 2020 - 12:02 PDT
      Investigating
      We are experiencing SMS delivery delays when sending messages to Malawi Telekom Networks. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted May 29, 2020 - 09:41 PDT