We are no longer experiencing API latency issue and timeouts across roles and realms. This incident has been resolved.
Posted Dec 03, 2025 - 21:25 PST
Update
We are observing recovery in the API latency and timeouts across roles and realms. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Dec 03, 2025 - 19:46 PST
Monitoring
We are observing recovery in the API latency and timeouts across roles and realms. We will continue monitoring the service to ensure a full recovery. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Dec 03, 2025 - 19:16 PST
Update
We are experiencing increased latency across roles and realms. Our engineers are working to resolve the issue. We will provide another update in an hour or as soon as more information becomes available. Potentially impacted products - Studio, Flex Application Platform, Flex Routing, Console Admin, Identity, Trust Hub, Event Streams
Posted Dec 03, 2025 - 18:35 PST
Update
We are experiencing increased latency across roles and realms. Our engineers are working to resolve the issue. We will provide another update in 30 minutes or as soon as more information becomes available.
We are currently investigating elevated latency and timeout errors for Twilio Rest API impacting multiple products. Our engineering team is actively working on the issue, and we will provide another update in 30 minutes or as soon as more information becomes available.