Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Failures to Rogers (302-720) and Fido (302-370) Canada Networks Using Toll Free Numbers
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery failures to Rogers (302-720) and Fido (302-370) Canada Networks Using Toll Free Numbers. This incident has been resolved.
      Posted Apr 01, 2021 - 12:38 PDT
      Monitoring
      We are observing successful SMS delivery to Rogers (302-720) and Fido (302-370) Canada Networks Using Toll Free Numbers. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Apr 01, 2021 - 10:42 PDT
      Update
      We are experiencing delivery failures sending to Rogers (302-720) and Fido (302-370) Canada Networks Using Toll Free Numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 Hour or as soon as more information becomes available.
      Posted Apr 01, 2021 - 10:29 PDT
      Investigating
      We are experiencing delivery failures sending to Rogers (302-720) and Fido (302-370) Canada Networks Using Toll Free Numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 Hour or as soon as more information becomes available.
      Posted Apr 01, 2021 - 09:24 PDT
      This incident affected: CARRIER NETWORK (SMS Long Code, North America, SMS Short Code, North America) and PROGRAMMABLE MESSAGING (SMS).