Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Credit Cards Incorrectly Declining for a Subset of Customers
Incident Report for Twilio
Resolved
We are no longer experiencing issues with credit cards incorrectly declining. This incident has been resolved.
Posted Mar 25, 2021 - 21:00 PDT
Monitoring
We’ve addressed the issue causing elevated failures for customer credit cards incorrectly declining and already observing successful payment processing. We will continue to monitor and expect to provide an update in 2 hours or as soon as more information becomes available.
Posted Mar 25, 2021 - 19:01 PDT
Update
We continue to experience customer credit cards incorrectly declining on the Twilio platform. We are investigating with our billing partner and will provide another update in 4 hours or as soon as more information becomes available.
Posted Mar 25, 2021 - 17:24 PDT
Update
We continue to experience customer credit cards incorrectly declining on the Twilio platform. We are investigating with our billing partner and will provide another update in 4 hours or as soon as more information becomes available.
Posted Mar 25, 2021 - 13:13 PDT
Update
We have discovered that customers who use Visa and Mastercard may also be impacted by this incident. We continue to experience customer credit cards incorrectly declining on the Twilio platform. We are investigating with our billing partner and will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 25, 2021 - 11:22 PDT
Update
We are experiencing customer Amex credit cards incorrectly declining on the Twilio platform. Customers may be unable to add AMEX credit cards due to the cards being declined erroneously with "zip code errors". The credit card declines may lead to customers being unable to add credit cards and customer accounts may be suspended if the recharge trigger and suspension trigger decline and funds cannot be added. We are investigating and will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 25, 2021 - 10:35 PDT
Investigating
Our monitoring systems have detected a potential issue with customers' credit cards incorrectly declining for billing and payments. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Mar 25, 2021 - 10:15 PDT
This incident affected: TWILIO PLATFORM (Billing).