Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Latency and Timeout Errors with Twilio Rest API Impacting Multiple Products
      Incident Report for Twilio
      Resolved
      Our engineering team has confirmed the issue is now fully resolved and the affected products and services are now operating normally.
      Posted Dec 10, 2021 - 14:19 PST
      Monitoring
      We have continued to see recovery to the API degradation causing latency and timeout errors for Debugger, Voice Services, Messaging Services, Messaging/Sync, Studio, Flex SDK, TaskRouter SDK, Flex UI, Flex API and Login, Flex Messaging, Video, Voice, Twilio Live, Event Streams, Verify, TaskRouter, Messaging Insights, Functions/Assets and Conversations. Our Engineers have mitigated the issue and have continued to observe recovery of products and services since 1PM PST. We will continue to monitor for system stability and provide an update in 30 minutes.
      Posted Dec 10, 2021 - 13:50 PST
      Identified
      Beginning 12:15 PM PST, Twilio started experiencing API degradation causing latency and timeout errors for Debugger, Voice Services, Messaging Services, Messaging/Sync, Studio, Flex SDK, TaskRouter SDK,Flex UI, Flex API and Login, Flex Messaging, Video, Voice, Twilio Live, Event Streams, Verify, TaskRouter, Messaging Insights, Functions/Assets and Conversations. Our Engineers have worked on mitigating the issue and we are seeing recovery of product and services since 1PM PST. The next update will be in 30 minutes.
      Posted Dec 10, 2021 - 13:20 PST
      Update
      We are currently investigating an issue with latency and timeout errors on Twilio's Rest API. Multiple products are impacted. Our engineers are working on the issue, and we will provide another update in the next 30 minutes or when more information becomes available.
      Posted Dec 10, 2021 - 12:51 PST
      Investigating
      Our monitoring systems have detected a potential issue with a spike in 4xx errors across multiple products. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Dec 10, 2021 - 12:39 PST
      This incident affected: FLEX (TaskRouter, Flex Application Platform, Flex Insights), PROGRAMMABLE VIDEO (Group Rooms, Peer-to-Peer Rooms, Recordings, Compositions, Network Traversal Service, Go Rooms), PROGRAMMABLE VOICE (PSTN, SIP Interface, Client Web, Client Mobile, Conference, Recording, Queue, Text-to-Speech, Recording Transcriptions, TwiML, Voice Insights, Speech Recognition), DEVELOPER TOOLS (Event Streams, Debugger & Alerts, REST API), ACCOUNT SECURITY (Verify), PROGRAMMABLE MESSAGING (MMS, SMS, Messaging Channels, Conversations, Messaging Insights), and TWILIO LIVE.