Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Billing Issues With Subset of IoT Customers
      Incident Report for Twilio
      Resolved
      Our engineers have deployed a fix, and the service has recovered fully. This incident has been resolved.
      Posted Jun 01, 2023 - 18:40 PDT
      Update
      Since midnight UTC today, IoT usage from May 28 through May 31st has been incorrectly counted twice when calculating your Twilio account balance. This would have caused your account balance to appear lower than it should and may have led to your credit card being charged to bring your account balance back up to amount set in your auto recharge settings. Our engineering team is currently working on stopping the double counting of the usage so your balance will be correctly reflected, including any additional funds that may have been added to your account from your auto recharge being triggered.

      We expect to provide another update in 4 hours, or as soon as we have more information.
      Posted Jun 01, 2023 - 17:19 PDT
      Update
      Since midnight UTC today, IoT usage from May 28 through May 31st has been incorrectly counted twice when calculating your Twilio account balance. This would have caused your account balance to appear lower than it should and may have led to your credit card being charged to bring your account balance back up to amount set in your auto recharge settings. Our engineering team is currently working on stopping the double counting of the usage so your balance will be correctly reflected, including any additional funds that may have been added to your account from your auto recharge being triggered.

      We expect to provide another update in 2 hours, or as soon as we have more information.
      Posted Jun 01, 2023 - 15:22 PDT
      Identified
      Since midnight UTC today, IoT usage from May 28 through May 31st has been incorrectly counted twice when calculating your Twilio account balance. This would have caused your account balance to appear lower than it should and may have led to your credit card being charged to bring your account balance back up to amount set in your auto recharge settings. Our engineering team is currently working on stopping the double counting of the usage so your balance will be correctly reflected, including any additional funds that may have been added to your account from your auto recharge being triggered.
      Posted Jun 01, 2023 - 14:13 PDT
      Update
      We've become aware of an issue with Billing under IoT. Our engineering team has been alerted and is actively investigating. We will update in 1 hour or as soon as we have more information.
      Posted Jun 01, 2023 - 13:46 PDT
      Investigating
      Our monitoring systems have detected a potential issue with IoT Billing. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jun 01, 2023 - 13:30 PDT
      This incident affected: TWILIO PLATFORM (Billing).