Given the current situation in Africa where multiple undersea Internet cables that serve Africa have been severed. Our Engineers have detected multiple network degradations over multiple countries in Africa, for that reason, we have merged this into one incident report. For the latest updates, please refer to our ongoing Status updates here: https://status.twilio.com/incidents/98qvm65n93ft
Posted May 14, 2024 - 18:03 PDT
Update
We are continuing to experience SMS delivery delays when sending messages to Mobilis Networks in Algeria. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hour or as soon as more information becomes available.
Posted May 14, 2024 - 17:00 PDT
Investigating
We are experiencing SMS delivery delays when sending messages to Mobilis Networks in Algeria. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted May 14, 2024 - 16:13 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).