Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Orange Network in Israel
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to Orange Network. This incident has been resolved.
      Posted Jan 12, 2023 - 08:12 PST
      Monitoring
      This incident causing SMS delivery delays when sending messages to Orange network in Israel was prematurely resolved in one of our previous posts. Please refer to https://status.twilio.com/incidents/yhb0rknw3w2r for previous updates. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available. We apologize for the inconvenience and for any confusion this may have caused.
      Posted Jan 12, 2023 - 06:17 PST
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).