Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Programmable Wireless SIMS Outside of the US Losing Connectivity
      Incident Report for Twilio
      Resolved
      We have not received any additional reports of Programmable Wireless SIMs outside of the United States losing connectivity due to this issue since our connectivity provider implemented their most recent workaround and we updated the incident to monitoring. We have yet to receive an updated timeline on when the permanent fix will be deployed but we are expecting it to be implemented in the next couple of weeks. In the meantime, the workaround in place should offer continued connectivity without you needing to take any additional action. We are resolving this incident. If we identify any new losses to connectivity due to this issue we will open a new incident. If you wish to get any additional updates on the progress of the permanent fix please open a support ticket.
      Posted Sep 23, 2022 - 14:03 PDT
      Update
      Our downstream connectivity partner has modified the international (non-US) roaming permissions on all existing Programmable Wireless SIMs to no longer expire. Additionally, while they continue to work on a permanent fix, they have put in place a process to identify and update any new SIMs that are activated or modified (e.g. Rate Plan changed) so that their roaming permissions also will not expire. You should no longer experience Programmable Wireless SIMs outside of the US losing connectivity due to this issue.

      We will continue to monitor the situation before resolving the incident. If you continue to experience issues though, please file a ticket with our support team.

      We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 22, 2022 - 18:42 PDT
      Update
      Our downstream connectivity partner has modified the international (non-US) roaming permissions on all existing Programmable Wireless SIMs to no longer expire. Additionally, while they continue to work on a permanent fix, they have put in place a process to identify and update any new SIMs that are activated or modified (e.g. Rate Plan changed) so that their roaming permissions also will not expire. You should no longer experience Programmable Wireless SIMs outside of the US losing connectivity due to this issue.

      We will continue to monitor the situation before resolving the incident. If you continue to experience issues though, please file a ticket with our support team.

      We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 21, 2022 - 18:17 PDT
      Update
      Our downstream connectivity partner has modified the international (non-US) roaming permissions on all existing Programmable Wireless SIMs to no longer expire. Additionally, while they continue to work on a permanent fix, they have put in place a process to identify and update any new SIMs that are activated or modified (e.g. Rate Plan changed) so that their roaming permissions also will not expire. You should no longer experience Programmable Wireless SIMs outside of the US losing connectivity due to this issue.

      We will continue to monitor the situation before resolving the incident. If you continue to experience issues though, please file a ticket with our support team.

      We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 20, 2022 - 18:18 PDT
      Update
      Our downstream connectivity partner has modified the international (non-US) roaming permissions on all existing Programmable Wireless SIMs to no longer expire. Additionally, while they continue to work on a permanent fix, they have put in place a process to identify and update any new SIMs that are activated or modified (e.g. Rate Plan changed) so that their roaming permissions also will not expire. You should no longer experience Programmable Wireless SIMs outside of the US losing connectivity due to this issue.

      We will continue to monitor the situation before resolving the incident. If you continue to experience issues though, please file a ticket with our support team.

      We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 19, 2022 - 18:18 PDT
      Update
      Our downstream connectivity partner has modified the international (non-US) roaming permissions on all existing Programmable Wireless SIMs to no longer expire. Additionally, while they continue to work on a permanent fix, they have put in place a process to identify and update any new SIMs that are activated or modified (e.g. Rate Plan changed) so that their roaming permissions also will not expire. You should no longer experience Programmable Wireless SIMs outside of the US losing connectivity due to this issue.

      We will continue to monitor the situation over the weekend before resolving the incident. If you continue to experience issues though, please file a ticket with our support team.

      We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 18, 2022 - 18:17 PDT
      Monitoring
      Our downstream connectivity partner has modified the international (non-US) roaming permissions on all existing Programmable Wireless SIMs to no longer expire. Additionally, while they continue to work on a permanent fix, they have put in place a process to identify and update any new SIMs that are activated or modified (e.g. Rate Plan changed) so that their roaming permissions also will not expire. You should no longer experience Programmable Wireless SIMs outside of the US losing connectivity due to this issue.

      We will continue to monitor the situation over the weekend before resolving the incident. If you continue to experience issues though, please file a ticket with our support team.

      We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 16, 2022 - 17:27 PDT
      Update
      Our carrier partner continues to investigate the root cause of the expiring international roaming permissions. We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 16, 2022 - 17:00 PDT
      Update
      Our carrier partner continues to investigate the root cause of the expiring international roaming permissions. We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 15, 2022 - 17:00 PDT
      Update
      Our carrier partner is continuing to investigate the root cause of the expiring international roaming permissions. We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 14, 2022 - 17:01 PDT
      Investigating
      Since August 5, Programmable Wireless SIM’s outside the US may unexpectedly lose connectivity. A previous incident related to this issue was opened on August 10. That incident can be viewed here: https://status.twilio.com/incidents/5x9n6wmgb5z6

      Since then, we have discovered new information about the incident and that all SIMs outside of the US may be at risk of losing connectivity. Our downstream connectivity partner believes the root cause of the issue is that international (non-US) roaming permissions that should be automatically renewing each month are not. This results in devices being blocked from establishing data sessions after the permission expires.

      We continue to investigate the issue with our downstream connectivity partner. We expect that they will need to make changes to their provisioning platform to fix the issue. Our downstream connectivity partner’s has a release tentatively planned for September 22.
      As a workaround, while we continue to investigate the root cause and long term remedy, if a Programmable Wireless SIM outside of the US loses connectivity, you can move the SIM to a Rate Plan with international roaming disabled. Once the update is finished, move the SIM back to the original Rate Plan with international roaming enabled. This process will remove and re-apply the international roaming permission for 1 MONTH from when the update finished. This process may need to be repeated until a long term fix is released.

      We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Sep 13, 2022 - 17:21 PDT
      This incident affected: INTERNET OF THINGS (Programmable Wireless).