Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS DLR Delays via a Subset of Twilio Short Codes to Multiple US Networks
Incident Report for Twilio
Resolved
We have consolidated the monitoring of MMS delivery issues. Please follow this incident for updates: https://status.twilio.com/incidents/v2z70b2xsnzd
Posted Nov 29, 2021 - 09:00 PST
Update
We are experiencing MMS DLR delays to multiple US networks via a small subset of Twilio short codes. Actual delivery delays are not being observed. Our engineers continue to with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 29, 2021 - 07:26 PST
Update
A previous update noted that delivery delays were observed via a subset of Twilio long codes; this was incorrect. We are experiencing MMS delivery delays to multiple US networks via a small subset of Twilio short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 29, 2021 - 07:05 PST
Investigating
Our monitoring systems have detected a potential issue with delivery delays to multiple US networks from a subset of Twilio long codes. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Nov 29, 2021 - 06:52 PST
This incident affected: CARRIER NETWORK (MMS Short Code, North America).