Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Continuation of SMS Delivery Receipt Delays To Digicel Network In Papua New Guinea
      Incident Report for Twilio
      Resolved
      The issue with SMS delivery delays receiving message delivery reports when sending to Digicel Network In Papua New Guinea has been resolved, and the service is functioning normally at this time.
      Posted May 21, 2022 - 18:11 PDT
      Monitoring
      We are observing recovery in SMS delivery delays receiving message delivery reports when sending to Digicel Network In Papua New Guinea. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 21, 2022 - 16:18 PDT
      Update
      We are continuing to experience delays in receiving message delivery reports when sending to Digicel Network In Papua New Guinea. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted May 21, 2022 - 01:43 PDT
      Investigating
      As a continuation of https://status.twilio.com/incidents/lwj4t36zn78f, which was accidentally resolved, we'll continue to provide updates on the SMS Delivery Receipt Delays To Digicel Network In Papua New Guinea. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 16 hours or as soon as more information becomes available.
      Posted May 20, 2022 - 12:31 PDT
      This incident affected: CARRIER NETWORK (SMS, APAC, SMS Delivery Notifications & Status Callbacks).