Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Receipt Delays To Digicel Network In Papua New Guinea
      Incident Report for Twilio
      Resolved
      This incident SMS Delivery Receipt Delays To Digicel Network In Papua New Guinea was accidentally set to resolved, and we'll continue to provide updates in the newly created incident. Please refer to https://status.twilio.com/incidents/hmpj18jmlr5m for further details. We apologize for any confusion this may have caused.
      Posted May 20, 2022 - 10:11 PDT
      Update
      We continue to experience SMS Delivery Receipt Delays To Digicel Network In Papua New Guinea. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 16 hours or as soon as more information becomes available.
      Posted May 20, 2022 - 09:47 PDT
      Update
      We are experiencing SMS Delivery Receipt Delays To Digicel Network In Papua New Guinea. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
      Posted May 20, 2022 - 01:59 PDT
      Update
      We are experiencing SMS Delivery Receipt Delays To Digicel Network In Papua New Guinea. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted May 19, 2022 - 22:03 PDT
      Update
      We are experiencing SMS Delivery Receipt Delays To Digicel Network In Papua New Guinea. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted May 19, 2022 - 20:05 PDT
      Investigating
      We are experiencing SMS Delivery Receipt Delays To Digicel Network In Papua New Guinea. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted May 19, 2022 - 19:08 PDT
      This incident affected: CARRIER NETWORK (SMS Delivery Notifications & Status Callbacks).