Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Outbound SMS Delivery Delays to MTN Network in Ghana
      Incident Report for Twilio
      Resolved
      We are still experiencing outbound SMS delivery delays when sending SMS to MTN Ghana. Our engineers are working with our carrier partner to resolve the issue. However, we will mark this incident as resolved and we will continue posting updates on the status here: https://status.twilio.com/incidents/0kxh2dqmqx4w
      Posted May 22, 2023 - 12:40 PDT
      Investigating
      We are experiencing outbound SMS delivery delays when sending messages to the MTN Network in Ghana. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted May 22, 2023 - 12:12 PDT
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).