Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Errors When Adding New Funds
      Incident Report for Twilio
      Resolved
      This incident is related to adding payment info to Twilio Platform. Please refer to https://status.twilio.com/incidents/lsfvk8gn24dw for further updates. We apologize for the inconvenience and for any confusion this may have caused.
      Posted Nov 30, 2022 - 09:21 PST
      Investigating
      Our monitoring systems have detected a potential issue when adding new funds. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Nov 30, 2022 - 09:16 PST
      This incident affected: TWILIO PLATFORM (Billing).