Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Verizon Toll-Free SMS and MMS
      Incident Report for Twilio
      Resolved
      This incident related to SMS and MMS delivery issues when sending messages to Verizon Toll-Free was accidentally resolved. Please refer to https://status.twilio.com/incidents/6vr3hkpplktx for further updates. We apologize for the inconvenience and for any confusion this may have caused.
      Posted May 25, 2022 - 18:49 PDT
      Update
      We are observing recovery in SMS and MMS delivery issues when sending messages to Verizon Toll-Free. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 25, 2022 - 18:41 PDT
      Update
      We are observing recovery in SMS and MMS delivery issues when sending messages to Verizon Toll-Free. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 25, 2022 - 16:37 PDT
      Update
      We are observing recovery in SMS and MMS delivery issues when sending messages to Verizon Toll-Free. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 25, 2022 - 16:29 PDT
      Update
      We are observing recovery in SMS and MMS delivery issues when sending messages to Verizon Toll-Free. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 25, 2022 - 16:29 PDT
      Monitoring
      We are observing recovery in SMS and MMS delivery issues when sending messages to Verizon Toll-Free. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 25, 2022 - 16:28 PDT
      Update
      We are experiencing SMS and MMS delivery issues when sending messages to Verizon Toll-Free. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted May 25, 2022 - 15:16 PDT
      Investigating
      Our monitoring systems have detected a potential issue with Verizon Toll-Free SMS and SMS Delays. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted May 25, 2022 - 15:05 PDT
      This incident affected: CARRIER NETWORK (SMS Toll-Free, North America, MMS Toll-Free, North America).