Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS and MMS Delivery Delays to US T-Mobile
      Incident Report for Twilio
      Resolved
      We are still experiencing issues with T-Mobile, however, we have consolidated all impacting products in to one incident. You can check the status of this here: https://status.twilio.com/incidents/mkf66gvhnsqf
      Posted Jun 15, 2020 - 14:02 PDT
      Update
      We are experiencing SMS and MMS delivery delays when sending or receiving messages to T-Mobile. This is for Short Code, Toll-Free and Long Codes. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Jun 15, 2020 - 12:51 PDT
      Update
      We are experiencing SMS delivery delays when sending or receiving messages to T-Mobile. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Jun 15, 2020 - 12:19 PDT
      Investigating
      Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jun 15, 2020 - 11:58 PDT
      This incident affected: CARRIER NETWORK (SMS Long Code, North America, MMS Long Code, North America, SMS Short Code, North America, MMS Short Code, North America, SMS Toll-Free, North America).