Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        SMS Delivery Delays to Cellcom Network in United States of America

        Incident Report for Twilio

        Resolved

        We are no longer experiencing SMS delivery delays when sending messages to Cellcom Network in United States of America. This incident has been resolved.
        Posted May 20, 2025 - 01:36 PDT

        Monitoring

        We are observing recovery in SMS delivery delays when sending messages to Cellcom Network in United States of America. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
        Posted May 19, 2025 - 23:57 PDT

        Update

        We continue to experience SMS delivery delays when sending messages to Cellcom Network in United States of America. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
        Posted May 19, 2025 - 17:14 PDT

        Update

        We are still experiencing SMS delivery delays when sending messages to Cellcom Network in United States of America. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
        Posted May 18, 2025 - 17:14 PDT

        Update

        We are still experiencing SMS delivery delays when sending messages to Cellcom Network in United States of America. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
        Posted May 17, 2025 - 17:23 PDT

        Update

        We are still experiencing SMS delivery delays when sending messages to Cellcom Network in United States of America. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
        Posted May 16, 2025 - 17:23 PDT

        Update

        We are still experiencing SMS delivery delays when sending messages to Cellcom Network in United States of America. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 16 hours or as soon as more information becomes available.
        Posted May 16, 2025 - 01:33 PDT

        Update

        We are still experiencing SMS delivery delays when sending messages to Cellcom Network in United States of America. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
        Posted May 15, 2025 - 17:40 PDT

        Update

        We are still experiencing SMS delivery delays when sending messages to Cellcom Network in United States of America. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
        Posted May 15, 2025 - 13:43 PDT

        Investigating

        We're reopening this StatusPage post since the previous one was resolved by mistake. Please refer to this current post for updates in this StatusPage post https://status.twilio.com/incidents/3r6f2vyftzls.

        We are still experiencing SMS delivery delays when sending messages to Cellcom Network in United States of America. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
        Posted May 15, 2025 - 11:45 PDT
        This incident affected: CARRIER NETWORK (SMS Long Code, North America, SMS Short Code, North America, SMS Toll-Free, North America).