The incident impacting MMS, SMS, OTT, Voice Insights, Verify and Lookup in US1 has been resolved and systems are operating normally at this time.
Posted Oct 03, 2025 - 09:40 PDT
Update
We are observing recovery to degradation across MMS, SMS, OTT, Voice Insights, Verify and Lookup in US1. We will continue to monitor closely. We will provide another updates in 30 minutes.
We are observing recovery to degradation across MMS, SMS, OTT, Voice Insights, and Lookup in US1. We will continue to monitor closely. We will provide another updates in 30 minutes.
Our monitoring systems have detected increased latency for the Lookup V1 and V2 API. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Oct 03, 2025 - 08:18 PDT
This incident affected: ACCOUNT SECURITY (Verify), DEVELOPER TOOLS (REST API), PROGRAMMABLE MESSAGING (MMS, SMS), and PROGRAMMABLE VOICE (Voice Insights).